Continue Shopping

Continue Shopping

Frequently Asked Questions

TLS Browser Security Warning

Last Updated: May 19, 2016 04:50PM CDT
If you receive a TLS Browser Security warning when visiting, or trying to checkout of our website, it indicates that your web browser version may be outdated. To be able to place an order from Put Me In The Story, it will be necessary to update your web browser to a version that is compatible with the required PCI Security Standards and TLS protocol. See the following links on information to update your browser:
 
Background on the PCI Security Standards: 

Put Me In The Story has developed a plan regarding the latest changes to the PCI DSS 3.1 standard, which includes changes to Transport Layer Security (TLS).

TLS and SSL are most widely recognized as the protocols that provide secure HTTP (HTTPS) for Internet transactions between Web browsers and Web servers. The PCI Security Standards Council released the v3.1 to the PCI DSS standard in April 2015. This means that Put Me In The Story must discontinue support for those protocols or ciphers, ensuring your ongoing security.

While the PCI Security Standards Council has extended the deadline to June 2018, Put Me In The Story takes this security vulnerability, and our customer's data, seriously and has therefore decided to proceed with plans to disable TLS 1.0 as waiting is not recommended by the PCI Security Standards Council.

For more information regarding this standard, please refer to the links below:

http://blog.pcisecuritystandards.org/migrating-from-ssl-and-early-tls
https://www.pcicomplianceguide.org/pci-dss-v3-1-and-ssl-what-you-should-do-now/

Please contact our Customer Care team with any questions or concerns.

Contact Us

739badb16ac96b8ab018e1e5dc4ed7ac@sourcebooks.desk-mail.com
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete